Tuesday, March 28, 2006

recovering from a change in device paths under HP/UX

Added a NIC to an HP/UX system and had to move the HSC SCSI card as a consequence. This meant that the device paths to the NIKE RAID array changed and the volume groups didn't mount on reboot. We had to import the volume groups like this

depot # strings lvmtab
/dev/vg00
wV60?{
/dev/dsk/c2t6d0
/dev/swdepot
wV60@
/dev/dsk/c3t0d0
/dev/tmp
wV60@
/dev/dsk/c3t0d1


The VG 'swdepot' was on /dev/dsk/c3t0d0 and tmp was on /dev/dsk/c3t0d1. To see where they've moved to

depot # ioscan -funC disk
Class I H/W Path Driver S/W State H/W Type Description
=====================================================================
disk 3 8/4.0.0 sdisk CLAIMED DEVICE DGC C2300WDR5
/dev/dsk/c4t0d0 /dev/rdsk/c4t0d0
disk 4 8/4.0.1 sdisk CLAIMED DEVICE DGC C2300WDR5
/dev/dsk/c4t0d1 /dev/rdsk/c4t0d1
disk 0 8/16/5.6.0 sdisk CLAIMED DEVICE SEAGATE ST34573N
/dev/dsk/c2t6d0 /dev/rdsk/c2t6d0


Because the old volume groups are in /etc/lvmtab it needs to be moved aside

depot # mv /etc/lvmtab /etc/lvmtab.OLD

Import the volume groups with

depot # vgimport swdepot /dev/dsk/c4t0d0
depot # vgimport tmp /dev/dsk/c4t0d1


Then activate them with

vgchange -a y swdepot
vgchange -a y tmp


Recreate /etc/lvmtab with vgscan -av and mount them or reboot.

No comments: